Problème à l'installation de Composer

Ce sujet est résolu
19341
,

Salut à tous,

Il se trouve que je rencontre un problème dès les premières lignes de codes fournis par http://getcomposer.org/

voici l'erreur

new-host-2:vendor olivierbaisse$ php -r "eval('?>'.file_get_contents('http://getcomposer.org/installer'));"
#!/usr/bin/env php
Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:
The detect_unicode setting must be disabled.
Add the following to the end of your `php.ini`:
    detect_unicode = Off
A php.ini file does not exist. You will have to create one.
If you can not modify the ini file, you can also run `php -d option=value` to modify ini values on the fly. You can use -d multiple times.

Je ne sais pas vraiment ou je dois lancer cette commande. Est ce directement à la racine du dossier Symfony, ou bien dans le dossier vendor ?

Symfony me dit que je suis sur PHP5.4.10 et quand je fais un

php -v

dans mon dossier Sites il me dit que je suis sur la version 5.3.15. J'ai donc fait une recherche sur ces deux dossiers, et seul le php5.4.10 existe. Une explication serait la bienvenue.

Je suis précise l'os : Mac OSX v10.7.5

4 Réponse

19341
,

j'ai fini par trouver la soultion sur ce lien

Il suffit d'ajouter ce paramètre

-d detect_unicode=Off

après la commande.

Comme ceci

curl -s getcomposer.org/installer | php -d detect_unicode=Off
581
,

Salut !

Ca vient tout simplement tu fait que la console utilise pas le même php que ton apache.

Donc déjà je te déconseille d'utiliser PHP5.4 puisque c'est dit par Sf2 dans le check.php.

A part ça, peu importe où tu lance ta commande, c'est pas relatif à l'endroit où tu le lance.

PS : le mieux pour installer composer ça reste d'utiliser CURL en faisant :

curl -sS https://getcomposer.org/installer | php
19341
,

D'accord, merci,

Mais comment je peux reconfigurer Apache en 5.3.15 ?

19341
,

j'ai toujours la meme erreur, HELP please

MacBook-Pro-de-Olivier:Symfony olivierbaisse$ curl -sS https://getcomposer.org/installer | php
#!/usr/bin/env php
Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:
The detect_unicode setting must be disabled.
Add the following to the end of your `php.ini`:
    detect_unicode = Off
A php.ini file does not exist. You will have to create one.
If you can not modify the ini file, you can also run `php -d option=value` to modify ini values on the fly. You can use -d multiple times.