Caractére

Ce sujet est résolu
Default
,

Bonjour je pose ma question,

voila alors je suis entrain de créer un site avec cakephp, mais lorsque j'ai créer ma page default.ctp je n'est pas les accent qui s'affiche correctement voila mon code pas encore finis:

<html>
    <head>
        <title>Anipassion</title>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
    </head>
    <body>
        <div id="sidebar">
            <h2>Category</h2>
            <ul>
                <?php
                $menu = $this->requestAction(array("controller"=>'Categories','action'=>'clist'));
                foreach ($menu as $m){
                $m=$m"Category"];
                ?>
                <li><?php echo $html->link($m"titre"],array('controller'=>'Posts','action'=>'Category',$m'id']))?></li>
                <?php
                }
                ?>
            </ul>
        </div>
        <div id="content">
            <?php
            echo $content_for_layout;
            ?>
        </div>
    </body>
</html>

4 Réponse

Default
,

il faut le mettre sur les variable qui sont destinées à l'affichage uniquement, pas le texte que tu ecris toi comme "category" ou un "à" antre la date et l'heure par exemple.

désolé pour le temps de réponse, j'avais pas de vignette "nouvel evenement" et j'avais un peu zappé ce sujet ^^

Default
,

salut, déjà je ne sais pas si c'est une version simplifiée que tu nous donne mais c'est pas valide HTML : pas de dcotype... ensuite, pour le meta charset, tu peux le mettre avec cake : echo $html->charset(); et par défaut c'est encodage UTF8 (regarde sur la doc pour voir les autres) et finalement, je présume que c'est l'affichage du texte du lien qui merde un peu... met utf8_encode (ou decode, je sais jamais le quel c'est ^^) au tour de $m'titre'] et ca marchera a merveille si tout va bien ;)

Default
,

Oui je n'est pas donner tout le code lol^^ mon doctype et déjà près, je vient de le mettre, merci de ton aide

Default
,

Bon alors je les fais pour un peut près tout lol^^ j'ai un contenu sur deux qui affiche les accent correctement