"Could not find a JavaScript runtime"

Default
,

Bonjour tout le monde,

j'explique brièvement mon problème : j'ai essayé d'installer Ruby on Rails grâce au RailsInstaller sur Windows 7. Tout se passe magiquement bien jusqu'à ce que j'essaye de lancer le serveur local au moyen de la commande suivante :

rails s

A ce moment-là, j'ai toute une série d'erreurs relatives à JavaScript apparemment :

C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/execjs-1.4.0/lib/execjs/runtimes.rb:51:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/execjs-1.4.0/lib/execjs.rb:5:in `<module:ExecJS>'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/execjs-1.4.0/lib/execjs.rb:4:in `<top (required)>'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `require'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in `require'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in `require'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.0.22/lib/bundler/runtime.rb:68:in `require'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.0.22/lib/bundler/runtime.rb:68:in `block (2 levels) in require'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.0.22/lib/bundler/runtime.rb:66:in `each'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.0.22/lib/bundler/runtime.rb:66:in `block in require'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.0.22/lib/bundler/runtime.rb:55:in `each'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.0.22/lib/bundler/runtime.rb:55:in `require'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/bundler-1.0.22/lib/bundler.rb:122:in `require'
        from C:/Sites/demo/config/application.rb:7:in `<top (required)>'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.rb:53:in `require'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.rb:53:in `block in <top (required)>'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.rb:50:in `tap'
        from C:/Ruby/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.rb:50:in `<top (required)>'
        from script/rails:6:in `require'
        from script/rails:6:in `<main>'

J'ai essayé maintes manipulations, comme installer la gemme d'ExecJS et de RubyRacer, en suivant les conseils de gens ayant le même soucis sur Stackoverflow. Rien n'a fonctionné. Quelqu'un ici saurait m'aider ?

1 Réponse

Default
,

J'ai réussi à lancer le serveur depuis le fichier "todo" fourni par défaut. Apparemment la création de nouveaux projets est foireuse.

Nouvelle erreur cette fois-ci :

cannot load such file -- sqlite3

Manque-t-il un composant ?