Class does not exist sous Linux. SF 2.4

Default
,

Bonjour,

Depuis quelques jours j'essaie de migrer mon projet Symfony qui tourne en ce moment sous Windows Server à Linux.

J'ai simplement repris l'ensemble du dossier (vendor inclus) car le projet est sous SF 2.4 et la pluspart des libs utilisés ne sont plus à jour ou ne supportent plus la V 2.4 de SF.

Je suis sous PHP5.6

J'obtiens une erreur que je ne comprends absolument pas simplement que la class en question existe.

J'ai supprimé le cache et fait un composer dump-autoload, sans succés je bloque toujours sur la même erreur.
Je vous remercie de votre aide.

```PHP Fatal error: Uncaught exception 'Doctrine\Common\Persistence\Mapping\MappingException' with message 'Class 'Partage\DataBundle\Entity\API' does not exist' in /var/www/websites//vendor/doctrine/common/lib/Doctrine/Common/Persistence/Mapping/MappingException.php:97\nStack trace:\n#0 /var/www/websites/weby/vendor/doctrine/common/lib/Doctrine/Common/Persistence/Mapping/RuntimeReflectionService.php(43): Doctrine\Common\Persistence\Mapping\MappingException::nonExistingClass('Partage\\DataBundl...')\n#1 /var/www/websites/weby/vendor/doctrine/common/lib/Doctrine/Common/Persistence/Mapping/AbstractClassMetadataFactory.php(268): Doctrine\Common\Persistence\Mapping\RuntimeReflectionService->getParentClasses('Partage\\DataBundl...')\n#2 /var/www/websites/weby/vendor/doctrine/common/lib/Doctrine/Common/Persistence/Mapping/AbstractClassMetadataFactory.php(298): Doctrine\Common\Persistence\Mapping\AbstractClassMetadataFactory->getParentClasses('Partage\\DataBundl...')\n#3 /var/www/websites/weby/vendor/doctrine/common/lib/Doctrine/Common/Per in /var/www/websites/weby/vendor/doctrine/common/lib/Doctrine/Common/Persistence/Mapping/MappingException.php on line 97


Voici mon composer.json

```{
    "autoload": {
        "psr-0": {
            "": "src/"
        }
    },
    "config": {
        "bin-dir": "bin",
        "disable-tls": false
    },
    "description": "The \"Symfony Standard Edition\" distribution",
    "extra": {
        "branch-alias": {
            "dev-master": "2.4-dev"
        },
        "incenteev-parameters": {
            "file": "apps/config/parameters.yml"
        },
        "symfony-app-dir": "apps/weby",
        "symfony-web-dir": "web/forum"
    },
    "license": "MIT",
    "minimum-stability": "alpha",
    "name": "symfony/framework-standard-edition",
    "require": {
        "php": ">=5.3.3",

        "doctrine/doctrine-bundle": "1.2.*",
        "doctrine/doctrine-fixtures-bundle": "dev-master",
        "doctrine/orm": "~2.2,>=2.2.3",
        "friendsofsymfony/jsrouting-bundle": "1.2.0",
        "friendsofsymfony/user-bundle": "2.0.*@dev",
        "incenteev/composer-parameter-handler": "~2.0",
        "leafo/lessphp": "v0.3.9",
        "rain/raintpl": "3.1.*",
        "sensio/distribution-bundle": "~3.0",
        "sensio/framework-extra-bundle": "~3.0",
        "sensio/generator-bundle": "2.3.*",
        "stof/doctrine-extensions-bundle": "1.1.*@dev",
        "symfony/assetic-bundle": "2.3.*",
        "symfony/monolog-bundle": "2.4.*",
        "symfony/swiftmailer-bundle": "2.3.*",
        "symfony/symfony": "2.4.*",
        "twig/extensions": "1.0.*",
        "whiteoctober/breadcrumbs-bundle": "dev-master",
    },
    "require-dev": {
    },
    "scripts": {
        "post-install-cmd": [
            "Incenteev\\ParameterHandler\\ScriptHandler::buildParameters",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile"
        ],
        "post-update-cmd": [
            "Incenteev\\ParameterHandler\\ScriptHandler::buildParameters",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
            "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile"
        ]
    },
    "type": "project"
}```



1 Réponse

20286
,

Hello

Je ne connais pas le Windows Serveur à Linux mais tu peux vérifier si ce n'est pas un problème de case sensitive ou un problème de '/'.
Peux-tu partager ton entity Partage\DataBundle\Entity\API stp