Impossible d'installer cocur/slugify

Ce sujet est résolu
232753
,

Bonjour,

Je suis en train de suivre les vidéos de Tutoriel Symfony par l'exemple et je suis arrivé au moment où on doit installer cocur/slugify.
Mais je rencontre un problème : quand j'utilise la commande "composer require cocur/slugify" l'erreur suivante apparait :

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - cocur/slugify v4.0.0 conflicts with symfony/http-kernel[v4.1.13].
    - cocur/slugify v4.0.0 conflicts with symfony/http-kernel[v4.1.13].
    - cocur/slugify v4.0.0 conflicts with symfony/http-kernel[v4.1.13].
    - Installation request for cocur/slugify ^4.0 -> satisfiable by cocur/slugify[v4.0.0].
    - Installation request for symfony/http-kernel (locked at v4.1.13) -> satisfiable by symfony/http-kernel[v4.1.13].

Installation failed, reverting ./composer.json to its original content.

Je n'arrive pas à comprendre le conflit entre http-kernel et slugify étant donné que dans la vidéo tout se passe bien et que j'ai bien initiliasé mon projet avec la commande suivante : composer create-project symfony/website-skeleton MaSuperAgence 4.1.99

Voici à quoi ressemble mon fichier composer.json :

{
    "name": "symfony/website-skeleton",
    "type": "project",
    "license": "MIT",
    "description": "A skeleton to start a new Symfony website",
    "require": {
        "php": "^7.1.3",
        "ext-ctype": "*",
        "ext-iconv": "*",
        "sensio/framework-extra-bundle": "^5.1",
        "symfony/asset": "*",
        "symfony/console": "*",
        "symfony/dotenv": "*",
        "symfony/expression-language": "*",
        "symfony/flex": "^1.3.1",
        "symfony/form": "*",
        "symfony/framework-bundle": "*",
        "symfony/monolog-bundle": "^3.1",
        "symfony/orm-pack": "*",
        "symfony/process": "*",
        "symfony/security-bundle": "*",
        "symfony/serializer-pack": "*",
        "symfony/swiftmailer-bundle": "^3.1",
        "symfony/translation": "*",
        "symfony/twig-bundle": "*",
        "symfony/validator": "*",
        "symfony/web-link": "*",
        "symfony/yaml": "*"
    },
    "require-dev": {
        "symfony/debug-pack": "*",
        "symfony/maker-bundle": "^1.0",
        "symfony/profiler-pack": "*",
        "symfony/test-pack": "*",
        "symfony/web-server-bundle": "*"
    },
    "config": {
        "preferred-install": {
            "*": "dist"
        },
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "App\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "App\\Tests\\": "tests/"
        }
    },
    "replace": {
        "paragonie/random_compat": "2.*",
        "symfony/polyfill-ctype": "*",
        "symfony/polyfill-iconv": "*",
        "symfony/polyfill-php71": "*",
        "symfony/polyfill-php70": "*",
        "symfony/polyfill-php56": "*"
    },
    "scripts": {
        "auto-scripts": {
            "cache:clear": "symfony-cmd",
            "assets:install %PUBLIC_DIR%": "symfony-cmd"
        },
        "post-install-cmd": [
            "@auto-scripts"
        ],
        "post-update-cmd": [
            "@auto-scripts"
        ]
    },
    "conflict": {
        "symfony/symfony": "*"
    },
    "extra": {
        "symfony": {
            "allow-contrib": false,
            "require": "4.1.*"
        }
    }
}

Merci d'avance pour vos réponses =)

3 Réponse

Default
,

c'est un nouveau projet ? Si oui pourquoi installer la version 4.1 ?

Le conflit est à cause de ceci :
https://github.com/cocur/slugify/blob/master/composer.json#L25-L28

Visiblement slugify mais en conflit les versions de Symfony qui ne sont plus supportées, update ton projet en Symfony LTS 4.4 ou la dernière version stable 5.2.

Pour info, si tu es sur un nouveau projet on ne crée jamais avec une version de Symfony qui n'est plus supportée!

Default
,

Info 2, slugify ne me semble plus nécessaire car maitnenant il exisite le package symfony/string pour la manipulation de string.

232753
,

Hello,

Merci pour ta réponse. Le projet a été créé de base en 4.1 pour suivre le tuto Symfony de l'époque jusqu'au bout pour être sûr d'avoir la même version que celle-ci.

J'ai au final réussi à installer une version inférieure (3.1, celle de la vidéo) de slugify et elle a marché sans problème, mais je prends note de ta remarque pour le package symfony/string.

Merci pour ton aide !