Installer Rails

Ce sujet est résolu
Default
,

J'ai le problème suivant quand je lance la commande gem install sinatra-reloader

ERROR: Error installing sinatra-reloader:

The 'eventmachine' native gem requires installed build tools.

Please update your PATH to include build tools or donwnload the DevKit

#j'ai bien chargé le devkit

from 'http://rubyinstaller.org/downloads" and follow the instructions

at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'

Est-ce que vous pouvez m'aider à installer ce DevKit? J'ai bien dézippé mon archive comme indiqué...

5 Réponse

6315
,

Je te recommande d'utiliser le RailsInstaller, c'est beaucoup plus simple et le DevKit, SqLite et Rails sont inclus, tu pourras toujours utiliser mysql et rails sans aucun soucis. Pour installer sinatra-reloader sous windows, je te conseil d'utiliser la version 0.5 du gem donc

gem install sinatra-reloader -v '0.5'
1
,

Pour le devkit tu as suivi les instruction pour l'installer ?

Default
,

Merci à visudex d'avoir partagé cette ressource intéressante. Pour le DevKit, j'aurai quand même bien aimé comprendre ce qui n'allait pas..

6315
,

Comme Grafikart l'a dit, es-tu sur de bien avoir suivi les instructions pour installer le DevKit, au cas où DevKit wiki Installation

Default
,

Pas sûr, je vais regarder ça de plus près. Merci.