Ma vue ne s'affiche pas en localhost

Default
,

Bonjour,

Voila je rencontre un petit problème avec symfony. Je tiens à préciser que je suis débutant et qu'avant d'attérir ici, j'ai effectué des recherches et testé divers choses.

Ce que j'ai fait

J'ai tout simplement entré une commande dans le terminal de mon VS code afin de généré automatiquement un controller et une vue du nom de HomeController. Voici la commande en question :

php bin\console make:controller

Ce que je veux

Je souhaite seulement afficher ma vue en localhost avec le routing automatiquement obtenu lors de la création du controller.

Ce que j'obtiens

J'obtiens une erreur 404. Il semblerait que l'URL n'est pas trouvable et j'en ignore la raison. J'ai pourtant bien suivi les tutoriels et ait même vérifié plusieurs fois si je ne m'étais pas trompé quelque part. A un moment, je me suis rendu compte que mon dépository était "doublé", alors j'ai rectifié le tire. Mais rien n'y fait pour le moment.

Voici l'erreur comme elle m'ait affichée :

Not Found
The requested URL was not found on this server.

Apache/2.4.41 (Win32) PHP/7.4.0 Server at localhost Port 80

Une idée de la raison pour laquelle j'ai cette erreur ?

Merci à vous !

1 Réponse

Default
,

bonsoir
a priorer il faut se positionner sur le dossier de ton site avec le terminal biensur puis tu lance ton serveur avec la commande
php -S 127.0.0.1:8000 -t public
apres la vue ca depand du choix du routage que tu fait annotation ou config sur le fichier route pour cela la doc ne manque pas il faut juste suivre pas a pas