cURL méthode GET ok mais méthode POST erreur

Default
,

Bonjour, je rencontre un problème et j'espère réussir à trouver de l'aide ici. :aie:

Alors voilà, j'appelle une API pour en utiliser des foncitonnalités. Pour "récupérer" le code donc j'ai besoin je lance d'abord la fonctionnalité sur POSTMAN puis je récupère le code que j'arrange ensuite comme j'en ai besoin. Cela marche très bien pour les fonctions GET, je récupère tout ce qu'il faut mais pas pour les fonctions POST. J'obtiens une erreur me disant qu'il y a besoin d'un "body" pour utiliser la fonction. Cependant je pense remplis le POSTFIELD comme il faut donc je ne vois pas d'ou vient l'erreur...
Voici mes codes, une en GET et une en POST ainsi que l'erreur obtenue:

Voici la fonction en GET qui me renvoie bien les informations voulues

$token_file=fopen("headers.txt","r");

        $i=0;
        while($i<2)
        {
            $token=fgets($token_file);
            $i++;
        }
        fclose($token_file);

$curl=curl_init();

        curl_setopt_array($curl,array(
            CURLOPT_URL=>"monURLGET",
            CURLOPT_RETURNTRANSFER=>true,
            CURLOPT_ENCODING=>"",
            CURLOPT_MAXREDIRS=>10,
            CURLOPT_TIMEOUT=>0,
            CURLOPT_FOLLOWLOCATION=>true,
            CURLOPT_HTTP_VERSION=>CURL_HTTP_VERSION_1_1,
            CURLOPT_CUSTOMREQUEST=>"GET",
            CURLOPT_HTTPHEADER=>array(
                $token),
        ));


        $parsee=json_decode(curl_exec($curl), true);
        curl_exec($curl);
        curl_close($curl);

Voici la fonction en POST qui me renvoie une erreur

$token_file=fopen("headers.txt","r");

        $i=0;
        while($i<2)
        {
            $token=fgets($token_file);
            $i++;
        }
        fclose($token_file);

 $curl=curl_init();

                    curl_setopt_array($curl,array(
                        CURLOPT_URL=>"monURLPOST",
                        CURLOPT_RETURNTRANSFER=>true,
                        CURLOPT_ENCODING=>"",
                        CURLOPT_MAXREDIRS=>10,
                        CURLOPT_TIMEOUT=>0,
                        CURLOPT_FOLLOWLOCATION=>true,
                        CURLOPT_HTTP_VERSION=>CURL_HTTP_VERSION_1_1,
                        CURLOPT_CUSTOMREQUEST=>"POST",
                        CURLOPT_POSTFIELDS=>"{\n\"nom\":\"test\",\n\"origine\":\"test\"\n}", //c'est normal qu'il y ai les " et \, dans une version précédente de l'API je le faisais  //avec et cela marchait très bien
                        CURLOPT_HTTPHEADER=>array(
                            $token,
                            "Content-Type:application/json"
                        ),
                    ));

                    curl_exec($curl);

                    curl_close($curl);

Voici l'erreur obtenue:

{"timestamp":"2020-01-19T15:53:23.926+0000","status":400,"error":"Bad Request","message":"Required request body is missing: public org.springframework.http.ResponseEntity fr.nom.apiFNC.LibraryController.fonction(fr.nom.apiFNC.model.json.User)","path":"chemin"}

Merci pour votre aide !