Installer WP en local dans mon dossier personnel sous Debian

Default
,

Bonjour,

Voila je rencontre un petit problème avec mon code. J'ai recréé une base de données WP sur mon PC de développement et j'ai exporté/importé les tables de mon blog. J'ai également transféré l'ensemble du contenu du répertoire 'wordpress' de mon site de production sur mon PC de développement dans le répertoire /home/pilipe/public_html. J'ai modifié le fichier wp-config.php avec les bonnes informations.

Ce que je fais

J'ai activé le module 'userdir' pour exécuter mon WP à partir d'un répertoire 'public_html' créé dans mon dossier personnel '/home/pilipe'. J'ai activé le module 'userdir' et je l'ai modifié ainsi :

<IfModule mod_userdir.c>
        UserDir public_html
        UserDir disabled root
        # Modifs par PI 15/06/2019 selon fr/Lamp - Debian Wiki
        <Directory /home/*/public_html>
                AllowOverride All
                Options MultiViews Indexes SymLinksIfOwnerMatch
                <Limit GET POST OPTIONS>
                        Order allow,deny
                        Allow from all
                </Limit>
                <LimitExcept GET POST OPTIONS>
                        Order deny,allow
                        Deny from all
                </LimitExcept>
        </Directory>
</IfModule>

J'ai également modifié le fichier 'apache2.conf' pour indiquer :

<Directory /home/pilipe/public_html/>
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
</Directory>

Mon hôte virtuel est paramétré ainsi :

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        ServerName localhost

        ServerAdmin webmaster@localhost
        #DocumentRoot /var/www/html
        DocumentRoot /home/pilipe/public_html

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

Ce que je veux

Je souhaite pouvoir ainsi créer un environnement de test sur mon PC de développement.

Ce que j'obtiens

J'obtiens une page blanche :(
Si j'intalle un simple 'index.php' dans 'public_html' avec

<?php phpinfo() ?>;

j'ai la page d'information de PHP qui s'affiche. D'ailleurs si je lance simplement 'localhost', la page d'information d'apache2 s'affiche également correctement. J'en déduis que le serveur apache2 est bien configuré et que le problème vient de mon environnement WP.