Vhost sur un intranet

5181
,

Bonjour, à toutes et à tous
J'ai mis un petit debian sur l'intranet de ma boite afin d'exposer mes travaux. J'ai installer les paquets APACHE, php, mysql dessus/
Accéssible via une url de type

http://10.236.25.11

J'ai donc déposer 2 applications dans
`/home/dev/www

/home/dev/www/app1

/home/dev/www/app2

J'ai effectué des liens symbolique dans le
/var/www/app1 et app2`

J'ai modifier le vhost par defaut à

/var/www

Les utilisateurs auront la liste des applications pour le moment comme indexé.

J'ai utiliser le design pattern mvc et je dois faire pointer un vhost dans le dossier public de chaque application, mais je n'arrive pas à ériger un vhost pour application 1 et application 2.

Mon apache plante toujours
Pouvez vous m'aider

<VirtualHost *:80/app1>
        DocumentRoot /home/dev/www/app1/public

        <Directory /home/dev/www/app1/public>
            Options -Indexes +FollowSymLinks
            AllowIOverride All
        </Directory>

</VirtualHost>

Je vous remercie d'avance

4 Réponse

107977
,

Bonjour,

Mon apache plante toujours

C'est à dire ?

Pour pouvoir accéder à des applications via ce genre d'url http://10.236.25.11/app1, votre config doit comporter des alias pour chaque applications sans créer de nouveau VirtualHost comme ceci:

<VirtualHost *:80>
        DocumentRoot /var/www
        <Directory /var/www>
            Options -Indexes +FollowSymLinks
            AllowIOverride All
        </Directory>

        # App 1
        Alias /app1 /var/www/app1/public
        <Directory /var/www/app1/public>
            Options -Indexes +FollowSymLinks
            AllowIOverride All
        </Directory>

         # App 2
        Alias /app2 /var/www/app2/public
        <Directory /var/www/app2/public>
            Options -Indexes +FollowSymLinks
            AllowIOverride All
        </Directory>
</VirtualHost>

Si tu bloques, oublie pas de détails en partageant ton/tes message(s) d'erreur(s)

5181
,

bonsoir , je vous remercie de la reponse.. je m attele des demain matin a effectuer ce vhost et je vois fait un retour..
je vous remercie bcm.
a demain...

5181
,

Bonsoir. Cela fonctionne pour le moment correctement.
Cependant j'ai un autre souci.
J'ai suivi a la lettre la formation avec php avancé et les psr
En local tout va bien lorsque j'utilise la commande

php -S localhost:8000 -d display_errors=1 -t public/

je suppose que pour avoir le meme comportement je dois donc utiliser un .htaccess
Voici celui que j'ai fait, celui situé dans le dossier public

# Disable server signature
ServerSignature Off

# Necessary to prevent problems when using a controller named "index" and having a root index.php
# more here: http://httpd.apache.org/docs/2.2/content-negotiation.html
Options -MultiViews


# Prevent people from looking directly into folders
Options -Indexes

DirectoryIndex index.php
# Activates URL rewriting (like myproject.com/controller/action/1/2/3)
RewriteEngine On
RewriteBase /app1/
# Redirige tout vers l'index : c'est le point d'entree du MVC


# If the following conditions are true, then rewrite the URL:
# If the requested filename is not a directory,
RewriteCond %{REQUEST_FILENAME} !-d
# and if the requested filename is not a regular file that exists,
RewriteCond %{REQUEST_FILENAME} !-f
# and if the requested filename is not a symbolic link,
RewriteCond %{REQUEST_FILENAME} !-l

##
# RewriteRule ^(.+)$ index.php?url=$1 [QSA,L]
##
# If you have any problems with requesting in your website remove (#) from begining of RewriteRule ^(.+)$ index.php/$1 [L]
# and add (#) to RewriteRule .* index.php?/$0 [PT,L,QSA].
##
RewriteRule ^(.*)$ index.php?/$1
# RewriteRule ^(.+)$ index.php/$1 [L]
# RewriteRule ^(.+)$ index.php/$1 [L,QSA]

# RewriteRule .* index.php?/$0 [PT,L,QSA]

J'ai une page blanche.
Je tente de changer des élements mais en vain.
Pouvez vous m'aider. Merci à tous d'avance.

107977
,

As-tu pensés à activer la réécriture d'url d'apache => sudo a2enmod rewrite ?
La config que j'ai donné est suffisante normalement :

<Directory /var/www/app1/public>
      Options -Indexes +FollowSymLinks
      AllowIOverride All
</Directory>