Problème installation SASS

Ce sujet est résolu
Default
,

Bonjour,

Voila je rencontre un petit problème avec Ruby.

Je souhaite installer SASS sur mon pc qui est sous windows 10 pro.
J'ai téléchargé Ruby 2.3.3 ici même : http://rubyinstaller.org/downloads/

Or, une fois installé, quand je tape :

gem install sass

dans l'invit de commande, une erreur apparait :

ERROR : While execution gem... (SocketError)
getnameinfo : Le fournisseur de service demandé n'a pas pu être chargé ou initialisé.

J'ai fait des recherches mais je ne trouve rien de concluant, c'est pourquoi je demande votre aide ici.
Merci beaucoup d'avance !

10 Réponse

57150
,

Regarde ici http://stackoverflow.com/questions/9962051/could-not-find-a-valid-gem-in-any-repository-rubygame-and-others

Default
,

Je pencherais pour un problème au niveau de la connexion, essaye de réinstaller ruby,

pourrais-tu essayer un

gem search sass
57150
,

Fait un ruby -v et un gem -v quel version as-tu ?

Default
,

Alors merci de vos reponses avant tout.
J'ai essayé sur un autre ordi qui est sur le même reseau, et cela a fonctionné.

Voici le résultat de la commande gem search sass:

REMOTE GEMS 
ERROR: While executing gem ... (SocketError)
getnameinfo : Le fournisseur de service demandé n'a pas pu être chargé ou initialisé.

Pour la commande ruby -v :

ruby 2.2.6p396 (2016-11-15 revision 56800) [x64-mingw32]

Pour la commande gem -v :

2.4.5.2
57150
,

Je crois que tu fais parti tu gem bugger faut que tu le mette à jour

Télécharges la dernière version de rubygem https://rubygems.org/downloads/rubygems-update-2.6.10.gem

puis dans ton terminal tu réalises ceci

cd ~/Downloads

gem install --local rubygems-update-2.6.10.gem
update_rubygems --no-ri --no-rdoc

Ensuite refais un coup de gem -v voir si c'est bien la dernière version

Et tu peux relancer ton

gem install compass
gem install sass
Default
,

Bonjour,

Alors je viens d'effectuer exactement ce que tu as listé, mais j'ai encore le même soucis alors que la version de gem est bien la 2.6.10 :/

57150
,

Je viens de voir un truc déjà tu as dis que tu as installé la version 2.3.3 de ruby, mais la version détecté est la 2.2.6p396

Check de ce côté la, sinon on va approfondire ça ^^

Default
,

C'est bon j'ai bien la 2.3.3 quand je fais un ruby -v mais toujours la même erreur :/

57150
,

as-tu fais un gem update avant ?

Sinon essaie en installant le gem direct

cd ~/Downloads
gem install --local compass-1.0.3.gem```
Default
,

Alors voilà.
Résultat d'un gem update :

Updating installed gem
ERROR: While executing gem ... (SocketError)
getnameinfo : Le fournisseur de service demandé n'a pas pu être chargé ou initialisé.

Et voila aprés avoir téléchargé le fichier gem compass-1.0.3.gem, et éxécuter l'instruction que tu m'as donné plus ahut :

ERROR : Could not find a valid gem 'rb-inotify' (>=0.9) in any repository

Voila voila ^^