mise en ligne d'un projet sous cakephp 3.x

Ce sujet est résolu
15370
,

Bonjour,

c'est la première fois que je fait un projet avec cakephp 3.x, j'étais habiué avec la version 2.x.
voila j'ai réaliser un site avec cakephp 3.x en local tout fonctionne Nickel (bien)
le souscis est que lorsque je fait le transfert du site vers le lserveur distant(hébergé le site en ligne) cela ne me renvoi pas d'erreur mais juste une page blanche sans code html car lorsque j'éssais de voir le code source de la page je n'ai rien .
j'aimerai savoir si il y'a une façon spécifique de mettre un site fait avec cake 3.x en ligne.

parceque la je suis surpris car j'ai eu a transférer un mini projet sous cakephp 3.x, même version sous un sous domaine dans un autre serveur et cela c'est bien passé la suis perdu, quelqu'un a une idée? SVP

9 Réponse

15370
,

résolu problème de config avec mon serveur dédié

Default
, Il a répondu à ma question !

essaie de mettre temporairement le debug à true, pour voir s'il te renvoit une erreur...

Default
, Il a répondu à ma question !

J'ai deja eu le même symptome il me semble, pour moi c'était la connexion à la base de donnée qui était mal parametrée (mauvais mot de passe) dû au transfert de l'environnement de dev à la prod. Et effectivement comme tu n'a pas de message de debug en prod...

15370
, Il a répondu à ma question !

la connexion à la base de donnée passe bien et j'ai changer la valeur du débug, tru, 1, mais rien toujours la page blanche

Default
, Il a répondu à ma question !

c'est un hébergeur mutualisé ou dedié?

Default
, Il a répondu à ma question !

l'urlRewriting est-il bien activé sur ton serveur ? et peux-tu utiliser les .htaccess correctement ?

Default
, Il a répondu à ma question !

dans le fichier /logs/error.log ou debug.log tu n'as rien ?

15370
, Il a répondu à ma question !

c'est un serveur dédié

Default
, Il a répondu à ma question !

la conf apache ou nginx est bonne? ton nom de domaine est associé au server? tu as regardé les logs comme alexyon la dit?