Erreur encodage Sass/ ruby

Default
,

Bonjour,

Voila je rencontre un petit problème avec mon code.

J'ai récupéré un fichier html/sass et bower.json pendant mon stage.
Oui mais voilà sur mon ordinateur personnel je ne peux plus compiler et j'ai une erreur qui s'affiche :

" Enconding::CompatibilityError : incompatible character encondings: CP850 and UTF-8 "
Je ne sais plus quoi faire, j'ai vidé les caches
J'ai essayé de compiler depuis Sublime ou par ligne de commande car en ligne de commande avec compass compile j'ai droit à : " Enconding::CompatibilityError on line ["87"] of C: incompatible character encoding: Windows-1252 and UTF-8

Je ne suis pas douée pour installer ou régler les problèmes de sass, ruby ou compass. Je suis douée pour faire de l'intégration front une fois que l'environnement est déjà installée x)

Si y en a un parmis vous qui règle ce problème, je le remercie fortement !

Bonne soirée.

1 Réponse

Default
,

Bonjour, le problème ne vient pas du chemin de mon dossier. Je viens de faire un compass compile en ligne de commande et voici mon message d'erreur :
DEPRECATION WARNING on line 87 of C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/compass-core-1.0.3/stylesheets/compass/css3/_deprecated-support.scss: #{} interpolation near operators will be simplified
in a future version of Sass. To preserve the current behavior, use quotes:

unquote('"$moz-"#{$experimental-support-for-mozilla} "$webkit-"#{$experimental-support-for-webkit} "$opera-"#{$experimental-support-for-opera} "$microsoft-"#{$experimental-support-for-microsoft} "$khtml-"#{$experimental-support-for-khtml}')

You can use the sass-convert command to automatically fix most cases.

DEPRECATION WARNING on line 92 of C:/Ruby22-x64/lib/ruby/gems/2.2.0/gems/compass-core-1.0.3/stylesheets/compass/css3/_deprecated-support.scss: #{} interpolation near operators will be simplified
in a future version of Sass. To preserve the current behavior, use quotes:

unquote('"$ie6-"#{$legacy-support-for-ie6} "$ie7-"#{$legacy-support-for-ie7} "$ie8-"#{$legacy-support-for-ie8}')

You can use the sass-convert command to automatically fix most cases.

write css/print.css
write css/styles.css

"

Visiblement cela viendrait de la configuration de l'environnement ou de compass ?