Livereload, .bat et fail

Default
,

Bonjour bonjour !

J'utilise LiveReload depuis un moment, depuis que j'ai vu passer le tuto dans mon flux RSS à vrai dire.

Je l'ai sur mon fixe, et sur mon laptop au boulot.

Seulement voila, j'ai reformaté mon fixe cet été, et donc j'ai perdu ma belle config de Ruby pour faire tourner le plugin.

Le hic, c'est que j'ai bien suivi le tuto, plusieurs fois même, en désinstallant et réinstallant tout etc, et là je sèche : quand je lance mon autorefresh.bat, la fenêtre s'ouvre et disparaît aussi tôt, sans que j'ai le temps de lire le message d'erreur.

J'ai bien tenté avec un Prt Scr bien calé, et en gros, Livereload n'est pas une fonction valide...

J'ai vu qu'un membre avait eu un problème similaire qui venait de sa version de Ruby, mais il n'en est rien : je suis sur la 1.8.6, et je ne l'ai pas mise à jour.

Du coup, si quelqu'un peut m'aiguiller, ça pourrait être sympa ;)

10 Réponse

Default
,

Salut,

Le tutoriel de Grafikart est certainement obsolète. Ça va te demander un effort supplémentaire mais je te conseille de lire les instructions qui sont présentes sur la page Github du projet. https://github.com/mockko/livereload il me semble que sur Windows, tu dois installer "Ruby development kit".

Après, je fais un peu de pub mais tu peux installer Virtualbox et mettre un machine virtuelle Linux. C'est totalement gratuit et c'est bien plus simple. Tu dois uniquement tapé une commande et Ruby est déjà installé dessus.

Salut et bonne chance.

Default
,

Malheureusement, j'ai déjà essayé via les instructions fournies sur Github, et via le Ruby DK à installer en suivant leur lien, mais même soucis : Livereload ne se lance pas.

Default
,

Et si tu le fait sans passer par le fichier .bat ? (je veux dire en faisant cd tonrépertoire et livereload)

Default
,

Je ré installerai et ré essaierai. Mais c'est nettement moins pratique.

Default
,

Je viens de découvrir ton problème :

Je cite le README de livereload : " LiveReload has been tested on Ruby 1.9.1 and 1.8.7". Dans ton premier post tu dis avoir mis la version 1.8.6 de Ruby. Le problème vient peut être de là.

Je te laisse essayer, sinon je ne vois pas d'où ça peut venir :o

Default
,

Bonjour,

Je me permet de remettre à jour ce sujet, vu que j'ai aussi un problème avec les fichiers .bat, après avoir fait et refait le tuto avec sucées, j'essaye d'utiliser le fichier .bat que je crée avec notepad++ et que je place dans le dossier que je veux utiliser, mais dés que je l'ouvre la console m'affiche "'livereload' n'est pas reconnu en tant que commande interne ou externe, un programme executable ou un fichier de commande.

Merci d'avance.

Default
,

Lors de l'installation as-tu bien cliqué sur une checkbox du genre "Add Ruby to your PATH variable" ?

Default
,

Oui oui comme préciser dans le tuto j'ai bien cocher les deux cases lors de l'installation.

Default
,

Personnellement la dernière fois que j'ai tenté de l'installer sur la version recommandée par le tuto sur le Ghitub de Livereload, il n'a pas pu l'installer... Tout simplement. Le plugin était introuvable.

Il se peut qu'il se soit passé la même chose pour toi sans que tu y prêtes attention.

Default
,

Malheureseument non, livereload s'est bien installé comme dans le tuto.