Cannot find module 'riot-games-api-nodejs'

Ce sujet est résolu
45305
,

Bonjour,
je souhaite utiliser l'api riot et j'ai donc installé le module riot-games-api-nodejs. J'ai procédé comme indiqué dans la documentation , et lors de l'appel du module

var riot = require('riot-games-api-nodejs');
riot.developerKey = Config.developerKey;

j'obtiens l'erreur

Error: Cannot find module 'riot-games-api-nodejs'
    at Function.Module._resolveFilename (module.js:336:15)
    at Function.Module._load (module.js:286:25)
    at Module.require (module.js:365:17)
    at require (module.js:384:17)
    at Object.<anonymous> (/home/ubuntu/workspace/index.js:3:12)
    at Module._compile (module.js:434:26)
    at Object.Module._extensions..js (module.js:452:10)
    at Module.load (module.js:355:32)
    at Function.Module._load (module.js:310:12)
    at Function.Module.runMain (module.js:475:10)

Je ne comprends pas d'ou viens le probleme car lors de l'installation je n'ai eu aucune erreur.
Si quelqu'un a une solution/explication je suis preneur :D

2 Réponse

Default
,

Bonjour,

Dans le package.json du module riot-games-api-nodejs il faut remplacer

  "main": "app.js",

par

  "main": "./lib/riot-games-api-nodejs.js",
45305
,

Merci beaucoup! Je n'avais pas pensé a regarder le fichier package.json