Erreur de l'installation de socket.io

Default
,

Bonjour,
Quand je fais un
npm install socket.io
j'ai ce message d'erreur

(J'ai fais un npm install -g node-gyp et j'ai python 3.x)

PS C:\Users\utilisateur\Desktop\node js\Chat> npm install socket.io
|


> bufferutil@1.1.0 install C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\engine.io\node
modules\ws\node_modules\bufferutil
> node-gyp rebuild

|
C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\engine.io\node_modules\ws\node_modules\bu
ferutil>if not defined npm_config_node_gyp (node "C:\Program Files (x86)\nodejs\node_modules\npm\bin\node-gyp-bin\\..\.
\node_modules\node-gyp\bin\node-gyp.js" rebuild )  else (node  rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Python executable "python" is v3.3.2, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack     at failPythonVersion (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\confi
ure.js:119:14)
gyp ERR! stack     at C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:108:9
     at ChildProcess.exithandler (child_process.js:742:7)
gyp ERR! stack     at ChildProcess.emit (events.js:110:17)
gyp ERR! stack     at maybeClose (child_process.js:1015:16)
gyp ERR! stack     at Socket.<anonymous> (child_process.js:1183:11)
gyp ERR! stack     at Socket.emit (events.js:107:17)
gyp ERR! stack     at Pipe.close (net.js:485:12)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "node" "C:\\Program Files (x86)\\nodejs\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js"
rebuild"
gyp ERR! cwd C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\engine.io\node_modules\ws\no
e_modules\bufferutil
gyp ERR! node -v v0.12.7
gyp ERR! node-gyp -v v2.0.1
gyp ERR! not ok

....

8 Réponse

10031
,

Bonsoir,

Désinstalle python et installe la 2.7.x à la place, ça devrait marcher si j'en crois les erreurs affichées.

Default
,

J'ai installer python 2.7 mais j'ai le même message d'erreur
(je mets tous le message d'erreur parce que le site considérer que c'était un spam)

...\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Python executable "python" is v3.3.2, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\config
ure.js:119:14)
gyp ERR! stack at C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:108:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:742:7)
gyp ERR! stack at ChildProcess.emit (events.js:110:17)
gyp ERR! stack at maybeClose (child_process.js:1015:16)
gyp ERR! stack at Socket. (child_process.js:1183:11)
gyp ERR! stack at Socket.emit (events.js:107:17)
gyp ERR! stack at Pipe.close (net.js:485:12)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "node" "C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" "
rebuild"
gyp ERR! cwd C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\engine.io\node_modules\ws\nod
e_modules\utf-8-validate
gyp ERR! node -v v0.12.7
gyp ERR! node-gyp -v v2.0.1
gyp ERR! not ok

bufferutil@1.1.0 install C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\engine.io\node_
modules\ws\node_modules\bufferutil
node-gyp rebuild

C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\engine.io\node_modules\ws\node_modules\buf
ferutil>if not defined npm_config_node_gyp (node "C:\Program Files (x86)\nodejs\node_modules\npm\bin\node-gyp-bin\....
\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Python executable "python" is v3.3.2, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\config
ure.js:119:14)
gyp ERR! stack at C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:108:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:742:7)
gyp ERR! stack at ChildProcess.emit (events.js:110:17)
gyp ERR! stack at maybeClose (child_process.js:1015:16)
gyp ERR! stack at Socket. (child_process.js:1183:11)
gyp ERR! stack at Socket.emit (events.js:107:17)
gyp ERR! stack at Pipe.close (net.js:485:12)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "node" "C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" "
rebuild"
gyp ERR! cwd C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\engine.io\node_modules\ws\nod
e_modules\bufferutil
gyp ERR! node -v v0.12.7
gyp ERR! node-gyp -v v2.0.1
gyp ERR! not ok
npm WARN optional dep failed, continuing utf-8-validate@1.1.0

utf-8-validate@1.1.0 install C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\socket.io-c
lient\node_modules\engine.io-client\node_modules\ws\node_modules\utf-8-validate
node-gyp rebuild

C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\socket.io-client\node_modules\engine.io-cl
ient\node_modules\ws\node_modules\utf-8-validate>if not defined npm_config_node_gyp (node "C:\Program Files (x86)\nodejs
\node_modules\npm\bin\node-gyp-bin\....\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Python executable "python" is v3.3.2, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\config
ure.js:119:14)
gyp ERR! stack at C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:108:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:742:7)
gyp ERR! stack at ChildProcess.emit (events.js:110:17)
gyp ERR! stack at maybeClose (child_process.js:1015:16)
gyp ERR! stack at Socket. (child_process.js:1183:11)
gyp ERR! stack at Socket.emit (events.js:107:17)
gyp ERR! stack at Pipe.close (net.js:485:12)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "node" "C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" "
rebuild"
gyp ERR! cwd C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\socket.io-client\node_modules
\engine.io-client\node_modules\ws\node_modules\utf-8-validate
gyp ERR! node -v v0.12.7
gyp ERR! node-gyp -v v2.0.1
gyp ERR! not ok
npm WARN optional dep failed, continuing bufferutil@1.1.0

bufferutil@1.1.0 install C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\socket.io-clien
t\node_modules\engine.io-client\node_modules\ws\node_modules\bufferutil
node-gyp rebuild

C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\socket.io-client\node_modules\engine.io-cl
ient\node_modules\ws\node_modules\bufferutil>if not defined npm_config_node_gyp (node "C:\Program Files (x86)\nodejs\nod
e_modules\npm\bin\node-gyp-bin\....\node_modules\node-gyp\bin\node-gyp.js" rebuild ) else (node rebuild )
gyp ERR! configure error
gyp ERR! stack Error: Python executable "python" is v3.3.2, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\config
ure.js:119:14)
gyp ERR! stack at C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\configure.js:108:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:742:7)
gyp ERR! stack at ChildProcess.emit (events.js:110:17)
gyp ERR! stack at maybeClose (child_process.js:1015:16)
gyp ERR! stack at Socket. (child_process.js:1183:11)
gyp ERR! stack at Socket.emit (events.js:107:17)
gyp ERR! stack at Pipe.close (net.js:485:12)
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "node" "C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js" "
rebuild"
gyp ERR! cwd C:\Users\utilisateur\Desktop\node js\Chat\node_modules\socket.io\node_modules\socket.io-client\node_modules
\engine.io-client\node_modules\ws\node_modules\bufferutil
gyp ERR! node -v v0.12.7
gyp ERR! node-gyp -v v2.0.1
gyp ERR! not ok
npm WARN optional dep failed, continuing utf-8-validate@1.1.0
npm WARN optional dep failed, continuing bufferutil@1.1.0
socket.io@1.3.6 node_modules\socket.io
├── has-binary-data@0.1.3 (isarray@0.0.1)
├── debug@2.1.0 (ms@0.6.2)
├── socket.io-parser@2.2.4 (isarray@0.0.1, debug@0.7.4, component-emitter@1.1.2, benchmark@1.0.0, json3@3.2.6)
├── socket.io-adapter@0.3.1 (object-keys@1.0.1, debug@1.0.2, socket.io-parser@2.2.2)
├── engine.io@1.5.2 (base64id@0.1.0, debug@1.0.3, engine.io-parser@1.2.1, ws@0.7.2)
└── socket.io-client@1.3.6 (indexof@0.0.1, to-array@0.1.3, debug@0.7.4, component-bind@1.0.0, object-component@0.0.3, co
mponent-emitter@1.1.2, backo2@1.0.2, has-binary@0.1.6, parseuri@0.0.2, engine.io-client@1.5.2)

10031
,

Bonjour,

il affiche toujours cette erreur :

Error: Python executable "python" is v3.3.2, which is not supported by gyp.

As-tu désintaller python 3.x avant d'installer la 2.7 ?

Default
,

Faut supprimer python 3 si tu veut que ce soit python 2.7 qui soit pris en compte.
je sais pas quel systeme tu utilise alors voila quelque pistes a suivre ^^

mac
linux
windows

c'est de petites piste que j'ai cherché vite fait, mais qui te donnerons des indications pour suivre ca un peut mieux

Default
,

Maintenant j'ai cette erreur
MSBUILD : error MSB3428: Impossible de charger le composant Visual C++ "VCBuild.exe". Pour corriger le problème, vous d
evez 1) installer le Kit de développement .NET Framework 2.0 SDK, 2) installer Microsoft Visual Studio 2005 ou 3) ajout
er l'emplacement du composant au chemin d'accès système, s'il est installé ailleurs. [C:\Users\utilisateur\Desktop\nod
e js\Chat\node_modules\socket.io\node_modules\engine.io\node_modules\ws\node_modules\bufferutil\build\binding.sln]

Default
,

ben c'est simple... l'erreur est en francais donc il suffit de télécharger le framework .NET qui correspond...

Default
,

J'ai téléchargé Framework 2.0 SDK et l'ai installé mais j'ai toujours le message d'erreur.

17162
,

Bonjour.
Et pour ce qui concerne Microsoft Visual C++ ... ?